【Ubuntu | port】Linux进程端口号冲突问题解决

发布时间:2026/10/2 17:11:38
【Ubuntu | port】Linux进程端口号冲突问题解决 服务器中运行项目端口号冲突描述问题1.检查8080端口号是哪个进程在使用。2.pid解决描述服务器中运行项目端口号冲突导致现在进行部署的项目启动失败。问题$dockercompose up-d[]Running8/9 ✔ Network weknora_WeKnora-network Created0.1s ✔ Volumeweknora_data-filesCreated0.0s ✔ Volumeweknora_postgres-dataCreated0.0s ✔ Volumeweknora_docreader-tmpCreated0.0s ✔ Container WeKnora-redis Started0.7s ✔ Container WeKnora-postgres Healthy11.2s ✔ Container WeKnora-docreader Healthy6.2s ⠼ Container WeKnora-app Starting11.4s ✔ Container WeKnora-frontend Created0.1s Error response from daemon: failed tosetup container networking: driver failed programming external connectivity on endpoint WeKnora-app(0766b2b42271497e1eda6fd593fee10dce367ea273827ffb39ae58bbe5af8e3f): failed tobindhostportfor0.0.0.0:8080:172.20.0.5:8080/tcp: address alreadyinuse上述很容易看出是端口号冲突问题1.检查8080端口号是哪个进程在使用。sudo ss -ltnp sport :8080接下来通过pid定位。2.pid查看启动命令通常能看到 jar、Python 脚本或项目路径ps-p12345-opid,ppid,user,lstart,args# 查看进程的工作目录sudoreadlink-f/proc/12345/cwd# 查看它是否由 systemd 服务管理sudosystemctl status12345--no-pager解决只能杀死就项目进程。或者我们就是直接修改weknora项目的端口号。使新配置生效在Weknora项目中的.env配置文件中修改APP_PORT8080:# 应用服务宿主机映射端口默认 8080仅影响宿主机访问不影响容器间通信。 APP_PORT8080使新配置生效:dockercompose config--quietdockercompose up-d--wait--wait-timeout180dockercomposeps-atips使用 up 应用配置变更无需重新拉取镜像。